Special Notes

  • MyDS Center is now guarded against the vulnerability of Heartbleed Bug in OpenSSL, a popular software library used by most major Internet services, including MyDS Center. All MyDS Center servers have been patched and are safe to use.
  • There is no evidence that private customer data was accessed using this vulnerability, but as a precaution we are asking all of our customers to reset their MyDS passwords.